Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

starting Mirth Admin from Firefox vs Konqueror

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • starting Mirth Admin from Firefox vs Konqueror

    I'm using Mirth 1.6.1 on CentOS 5.

    I noticed that if I start the Mirth Administrator (via Java Webstart) from Firefox, then when I tried to import a channel definition xml file, Mirth generates the following error when I tried to save the channel. But if I start it from Konqueror, this error does not occur even though I was importing the exact same xml file. Any idea what's going on?

    Thanks,
    Dave


    -----------------------------


    com.webreach.mirth.client.core.ClientException: method failed: HTTP/1.1 500 lastModified : lastModified
    ---- Debugging information ----
    required-type : com.webreach.mirth.model.Channel
    cause-message : lastModified : lastModified
    class : com.webreach.mirth.model.Channel
    message : lastModified : lastModified
    line number : 7
    cause-exception : com.thoughtworks.xstream.mapper.CannotResolveClass Exception
    -------------------------------
    com.webreach.mirth.client.core.ServerConnection.ex ecutePostMethod(ServerConnection.java:98)
    com.webreach.mirth.client.core.Client.updateChanne l(Client.java:182)
    com.webreach.mirth.client.ui.Frame.updateChannel(F rame.java:1089)
    com.webreach.mirth.client.ui.ChannelSetup.saveChan ges(ChannelSetup.java:905)
    com.webreach.mirth.client.ui.Frame$23.doInBackgrou nd(Frame.java:2288)
    com.webreach.mirth.client.ui.Frame$23.doInBackgrou nd(Frame.java:2300)
    org.jdesktop.swingworker.SwingWorker$1.call(Unknow n Source)
    java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
    java.util.concurrent.FutureTask.run(FutureTask.jav a:138)
    org.jdesktop.swingworker.SwingWorker.run(Unknown Source)
    java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:885)
    java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:907)
    java.lang.Thread.run(Thread.java:619)

    Post edited by: docinthebox, at: 01/08/2008 08:46
Working...
X