Announcement

Collapse
No announcement yet.

max_allowed_packet

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • max_allowed_packet

    I am using Mirth 3.0.1.7051 got an error of
    [2015-01-28 14:38:25,970] ERROR (com.mirth.connect.donkey.server.channel.Channel:1 526): An error occurred in channel ccda_advocare_emr (285c5e1b-d912-410d-9f7d-1faad38ed696) while processing message ID 3232 from the source queue
    java.lang.RuntimeException: com.mirth.connect.donkey.server.data.DonkeyDaoExce ption: com.mysql.jdbc.PacketTooBigException: Packet for query is too large (1446183 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    at com.mirth.connect.donkey.server.channel.Channel.ha ndleDestinationChainThrowable(Channel.java:1497)
    at com.mirth.connect.donkey.server.channel.Channel.pr ocess(Channel.java:1424)
    at com.mirth.connect.donkey.server.channel.Channel.pr ocessSourceQueue(Channel.java:1524)
    at com.mirth.connect.donkey.server.channel.Channel.ru n(Channel.java:1511)
    at java.lang.Thread.run(Unknown Source)Caused by: com.mirth.connect.donkey.server.data.DonkeyDaoExce ption: com.mysql.jdbc.PacketTooBigException: Packet for query is too large (1446183 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    at com.mirth.connect.donkey.server.data.jdbc.JdbcDao. insertContent(JdbcDao.java:244)
    at com.mirth.connect.donkey.server.data.jdbc.JdbcDao. insertMessageContent(JdbcDao.java:172)
    at com.mirth.connect.donkey.server.data.buffered.Buff eredDao.executeTasks(BufferedDao.java:98)
    at com.mirth.connect.donkey.server.data.buffered.Buff eredDao.commit(BufferedDao.java:74)
    at com.mirth.connect.donkey.server.data.buffered.Buff eredDao.commit(BufferedDao.java:61)
    at com.mirth.connect.donkey.server.channel.Destinatio nChain.call(DestinationChain.java:286)
    at com.mirth.connect.donkey.server.channel.Channel.pr ocess(Channel.java:1422)
    ... 3 moreCaused by: com.mysql.jdbc.PacketTooBigException: Packet for query is too large (1446183 > 1048576). You can change this value on the server by setting the max_allowed_packet' variable.
    at com.mysql.jdbc.MysqlIO.send(MysqlIO.java:3865)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:25 51)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java :2731)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionIm pl.java:2815)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P reparedStatement.java:2155)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:2458)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:2375)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:2359)
    at com.mirth.connect.donkey.server.data.jdbc.JdbcDao. insertContent(JdbcDao.java:241)
    ... 9 more
    I cannot find where I can change the max_allowed_packet. Can you point me to the right direction. Thanks,

  • #2
    Old thread but someone may stumble on it:

    This setting is in the MySQL server config, not Mirth.

    The key info in the above is:

    "com.mysql.jdbc.PacketTooBigException: Packet for query is too large ([your data size] > [current MySQL limit])."

    Examine mysql at the server configuration: Server Variables, System Variables, locate:

    max_allowed_packet.

    ...Observe that the packet = the value indicated in the channel. Then consider increasing
    the mysql limit. (do your homework on that limit first I should think...)

    Comment

    Working...
    X