Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Soap sender/proxy problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Soap sender/proxy problem

    Hi,

    I have set up a channel with a soap sender but can't get the methods. I always get this message in the JBoss Console:

    11:36:17,353 WARN [com.webreach.mirth.server.util.WebServiceReader] Unable to read WSDL location: http://machine:8080/dir/service?wsdl

    The URL is correct and it works fine if I take the URL of a soap listener, I think the problem is the proxy. Can somebody tell me where to configure that in mirth? Do I have to add a line in the mirth.propoerties?

    Thanks :S

  • #2
    Re:Soap sender/proxy problem

    You may wish to verify that your firewall isn't blocking Mirth's request for the wsdl. I ran into this same issue... turned off my local firewall and suddenly Mirth was able to find the wsdl.

    Comment


    • #3
      Re:Soap sender/proxy problem

      I ran into the same issue. However, my local firewall is not running - i am attempting to contact a web service outside of my domain (which i can do through IE, .NET, etc.) and i'm guessing the corporate firewall is blocking my connection.

      Is it possible to change the port that the proxy is running on to avoid being blocked by the firewall? If not, can you tell me which port it IS running on so that i can request opening this port up on a corporate level?

      Thanks
      Jason

      Comment


      • #4
        Re:Soap sender/proxy problem

        For those who read this in the future - it appears that the SOAP proxy runs on port 4202. If your firewall is blocking this connection try unblocking this port.
        Thanks
        Jason

        Comment

        Working...
        X