No announcement yet.

SFTP Writer Auth fail

  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP Writer Auth fail


    I need to upload files to a SFTP site so I created a SFTP File Writer and filled the sftp address and credentials boxes, but when I click the 'Test Write' button I get an error that says "Unable to connect to s, Reason Auth fail", which is weird because the credentials work just fine when I try with FileZilla. I'm attaching a screenshot of my file writer settings, also my password does not have any weird chars, it has only numbers and letters in upper and lowercase, but my user name has an underscore in the middle of it, I'm not sure if that could be the cause of the issue.

    I'm not really sure what to do next, any help would be appreciated.

    I use Mirth
    Attached Files

  • #2
    I removed the underscore from the username and I still get the same error, I have never had this problem before as I currently have other SFTP channels that work fine.

    Nobody has any suggestion for this? is this a java issue? is this some sort of configuration issue with the SFTP site?

    Please help


    • #3
      Do you only have write access? We just ran into similar issue. The Test Write button fails on our side. They tech on the other site replied with: "Both some form of “stat” command, one of which is a permission denied (probably trying to change directories) and another that gives a “file not found” error."

      It looks like the writer is trying to either change directories or read files. In our case those are not allowed on the destination server.

      We also tried just sending a test file instead of the button, but that gave us the same result.

      They appear to be connecting fine, but the connector is sending commands that that user doesn't have permissions to do.

      Can someone from mirth take a look at what commands the test button and/or the sftp writer are sending? Is it possible to have an issue opened up for a write-only option?

      EDIT: Forgot my version: Mirth Connect Server
      Last edited by clarkmirth; 06-22-2015, 09:22 AM. Reason: add connect version


      • #4
        I faced the same Problem.

        This seems to work:

        Modify /etc/ssh/sshd_config on the ssh-server (enable PasswordAuthentication):

        # To disable tunneled clear text passwords, change to no here!
        # PasswordAuthentication no
        PasswordAuthentication yes

        Restart sshd



        • #5
          We found out our issue. The vendor we were trying to connect to had a white paper that was incorrect. They had us connecting to the root folder in the white-paper, but that was wrong, so our issue was all vendor related.