Announcement

Collapse
No announcement yet.

installing mirth 1.7 mirth-1.7.0.3185

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • installing mirth 1.7 mirth-1.7.0.3185

    Hi,

    I just downloaded the mirth 1.7 beta software. I have extracted the zip file into

    C:\mirth-1.7.0.3185\ folder (directory) on my Windows XP Pro SP2 workstation.

    When I click on InstallMirth-NT.bat, it will create service called mirth.




    what does Mirth.bat file do?

    When I click on Mirth Manager.exe, a new icon appears in the system tray.
    When I click on Show Manger in Mirth, in the Service tab, if I click on Start, it gives me an error message.

    also if i click on Administrator, I will see message Java startint..., and then an error message.

    CouldNotLoadArgumentException[ Could not load file/URL specified: http://localhost:8080/webstart.jnlp?time=1198517711960]
    at com.sun.javaws.Main.launchApp(Unknown Source)
    at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
    at com.sun.javaws.Main$1.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)


    So, How do I install Mirth 1.7 and start playing with it?

    thanks,
    baziz

  • #2
    Re:installing mirth 1.7 mirth-1.7.0.3185

    I ran into what might be a similar problem. Running Fedora Core 8, launching Administrator gave an error about missing files. Turns out the zip failed to expand MRJToolkitStubs.jar into ./client-lib. jar is in zip, copied into client-lib, Administrator starts okay after that.

    Still see a problem with the client though. After you run it for a bit some of the menu items go non-responsive (Settings, Events, Plugins). Eventually entire client is non-responsive. Tried upping java heap size to 512, seems to help a bit but still client ends up non-responsive.

    les

    Comment


    • #3
      Re:installing mirth 1.7 mirth-1.7.0.3185

      Hello,

      Where did you get this version ? i can not find this setup.

      If it is directly from SVN when I import (with TortoiseSVN) , it asks me a username/password and anonymous does not work.

      Please help me !

      Comment


      • #4
        Re:installing mirth 1.7 mirth-1.7.0.3185

        You can get it here :
        http://www.mirthproject.org/index.ph...ask=view&id=68

        Comment


        • #5
          Re:installing mirth 1.7 mirth-1.7.0.3185

          baziz wrote:
          Hi,

          I just downloaded the mirth 1.7 beta software. I have extracted the zip file into

          C:mirth-1.7.0.3185 folder (directory) on my Windows XP Pro SP2 workstation.

          When I click on InstallMirth-NT.bat, it will create service called mirth.




          what does Mirth.bat file do?

          When I click on Mirth Manager.exe, a new icon appears in the system tray.
          When I click on Show Manger in Mirth, in the Service tab, if I click on Start, it gives me an error message.

          also if i click on Administrator, I will see message Java startint..., and then an error message.

          CouldNotLoadArgumentException[ Could not load file/URL specified: http://localhost:8080/webstart.jnlp?time=1198517711960]
          at com.sun.javaws.Main.launchApp(Unknown Source)
          at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
          at com.sun.javaws.Main$1.run(Unknown Source)
          at java.lang.Thread.run(Unknown Source)


          So, How do I install Mirth 1.7 and start playing with it?

          thanks,
          baziz
          Installing the service makes it so windows manages Mirth as a service rather than just clicking mirth.bat. If you install the service, just open the mirth-manager and you should be able to start the service from there. Then, click the administrator button once it's started.
          Brendan Haverlock | Mirth Software Engineer | Mirth Corporation

          Comment


          • #6
            Re:installing mirth 1.7 mirth-1.7.0.3185

            Hello,
            I've also downloaded mirth 1.7 beta and extracted the zip on a Windows XP SP2 workstation. When I attempt to start the service, I receive the error "Error 1067: The process terminated unexpectedly". If I attempt to start the service through the Mirth Server Manager, I receive the error "The Mirth service could not be started. Please verify that it is installed and not already started". I have JRE 6 Update 3 installed. The wrapper.log shows the following:

            STATUS | wrapper | 2007/12/27 15:35:52 | --> Wrapper Started as Service
            STATUS | wrapper | 2007/12/27 15:35:53 | Launching a JVM...
            INFO | jvm 1 | 2007/12/27 15:35:53 | Wrapper (Version 3.2.1) http://wrapper.tanukisoftware.org
            INFO | jvm 1 | 2007/12/27 15:35:53 |
            INFO | jvm 1 | 2007/12/27 15:35:53 | WrapperSimpleApp: Unable to locate the class com.webreach.mirth.server.launcher.MirthLauncher: java.lang.UnsupportedClassVersionError: com/webreach/mirth/server/launcher/MirthLauncher (Unsupported major.minor version 49.0)
            INFO | jvm 1 | 2007/12/27 15:35:53 |
            INFO | jvm 1 | 2007/12/27 15:35:53 | WrapperSimpleApp Usage:
            INFO | jvm 1 | 2007/12/27 15:35:53 | java org.tanukisoftware.wrapper.WrapperSimpleApp {app_class} [app_parameters]
            INFO | jvm 1 | 2007/12/27 15:35:53 |
            INFO | jvm 1 | 2007/12/27 15:35:53 | Where:
            INFO | jvm 1 | 2007/12/27 15:35:53 | app_class: The fully qualified class name of the application to run.
            INFO | jvm 1 | 2007/12/27 15:35:53 | app_parameters: The parameters that would normally be passed to the
            INFO | jvm 1 | 2007/12/27 15:35:53 | application.
            STATUS | wrapper | 2007/12/27 15:35:55 | <-- Wrapper Stopped

            I had the same issue when I attempted to install and run Mirth 1.6. Is there anything obvious I am forgetting to do/check to get this up and running? Baziz, have you had any luck?

            Thank you,
            Jacky

            Comment


            • #7
              Re:installing mirth 1.7 mirth-1.7.0.3185

              Jacky - what Java version do you have? (You can check by going to the Command Prompt and typing: java -version)

              Mirth requires JRE 1.5.
              Chris Lang

              Comment


              • #8
                Re:installing mirth 1.7 mirth-1.7.0.3185

                Hi Chris - thanks for the response. When I ran the command you provided it was showing an old version (1.3) even though I had uninstalled java. I found reference to that version in an oracle directory (C:\Program Files\Oracle\jre\1.3.1) so when I renamed the folder and reinstalled java 1.5 I was successful. I'm now up and running.

                Jacky

                Comment

                Working...
                X