Announcement

Collapse
No announcement yet.

Can't login to Mirth Connect Administrator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't login to Mirth Connect Administrator

    I have Mirth Connect v3.1.0 installed and Java v8 update 25. I get to the Mirth Connect Administrator and try to login with the default username and password: admin. I get the following error message: There was an error connecting to the server at the specified address. Please verify that the server is up and running. I am using the default 'derby' DB, please see details below:
    Web Start Port: 8080
    Admin Port: 8443

    Database URL: jdbc:derby:${dir.appdata}/mirthdb;create=true
    Username and Password: admin
    Server: https://localhost:8443

    I am able to ping 'localhost' with successful response.
    nslookup on localhost returns fully qualified name and IP Address.

    I've looked at mirth.properties, has correct DB URL and username and password.

    Any suggestions?

  • #2
    Are you launching the Administrator from a different machine than the one running the server? Are you able to get to the main launch page at http://<your server IP>:8080?
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      I am launching administrator on same machine with the server. I can get to http://localhost:8080. It seems ports 8080 and 8443 that work fine on Win7, might be occupied by other process on Win8. Any other suggestions? Thanks for the reply.

      Comment


      • #4
        Try to change Port

        If you are facing issue with port number, you can change port number in conf/mirth.properties. then restart the server and try.
        ViSolve Interoperability Team,
        Visolve Inc,
        E-Mail:
        Web:

        Comment


        • #5
          If you are still having trouble logging into the Administrator with 3.1.0+, there are a few steps you can try.

          1. Try downgrading to the latest version of Java 7
          2. Upgrade to at least 3.1.1 and set the client protocols in mirth.properties to "https.client.protocols = TLSv1"
          Last edited by wayneh; 02-03-2015, 10:43 AM.

          Comment


          • #6
            Having the same problem...

            Trying to install Mirth 3.2.1.7650.b40-windows-x64. The Connect Server Manager opens, the Administrator launches from Java 7 (build 1.7.0-b147), but when I login with Mirth default login it says: There was an error connecting to the server at the specified address (https://localhost:8443).

            When I uninstall Mirth, and reinstall my old version (Mirth 3.0.2.7140.b1159-windows-x64) with the exact same settings my login authenticates and Administrator opens. Using the same ports, same computer, same Java. What is different in these two versions that would keep me from logging into Administrator? Any ideas?

            (I've cleared the Java cache from Control Panel, and manually by going to the directory). Running mirth on my local machine.

            Comment

            Working...
            X