Announcement

Collapse
No announcement yet.

installation argument dir.appdata and dir.logs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • installation argument dir.appdata and dir.logs

    Hello,

    This topic is linked to silent install.
    Most of the configuration works but dir.appdata and dir.logs seem to be ignored

    The command line used is the following one

    mirthconnect-3.0.3.7171.b1190-windows-x64.exe -q
    -Vsys.javaHome=%MY_JAVA_HOME%
    -Vsys.installationDir=%MY_PROGRAMS%\MirthConnect
    -Vdir.appdata=%MY_DATA%\MirthConnect\appdata
    -Vdir.logs=%MY_DATA%\MirthConnect\logs
    -Vhttp.port=31486
    -Vhttps.port=31487
    -Vhttp.contextpath=/MirthConnect

    set MY_PROGRAMS=d:\programs
    set MY_DATA=d:\data

    The behavior is that the wrong folders are used and the %MIRTH_HOME%\preferences contains
    #install4j response file for Mirth Connect 3.0.3.7171.b1190
    #Fri Jul 11 03:10:39 CEST 2014
    sys.programGroupDisabled$Boolean=false
    sys.installationDir=d\:\\programs\\MirthConnect
    sys.languageId=en
    dir.logs=d\:\\programs\\MirthConnect\\logs
    executeLauncherAction$Boolean=true
    installServiceAction$Boolean=true
    password.minlength$Long=0
    sys.component.1357$Boolean=true
    showFileAction$Boolean=true
    https.port$Long=31487
    http.port$Long=31486
    password.minupper$Long=0
    password.minspecial$Long=0
    sys.programGroupName=Mirth Connect
    password.minnumeric$Long=0
    dir.appdata=d\:\\programs\\MirthConnect\\appdata
    sys.component.33$Boolean=true
    password.minlower$Long=0
    sys.component.31$Boolean=true
    sys.programGroupAllUsers$Boolean=true
    sys.adminRights$Boolean=true

    The %MIRTH_HOME%\conf\mirth.properties contains
    # Mirth Connect configuration file
    # directories
    dir.appdata = d:\\programs\\MirthConnect\\appdata
    dir.tempdata = ${dir.appdata}/temp
    # ports
    http.port = 31486
    https.port = 31487
    ...

    If I remove the -q parameter and force in the installer GUI the fine folder
    everything is fine :
    the right folders are used and the %MIRTH_HOME%\preferences contains
    ...
    sys.installationDir=d\:\\programs\\MirthConnect
    dir.logs=d\:\\data\\MirthConnect\\logs
    dir.appdata=d\:\\data\\MirthConnect\\appdata
    ...

    Please, can someone explain me my mistake?

    Thank you

  • #2
    It appears you are to setting your variables after calling the setup. You need to set the values before calling the setup so that the setup can use the values.

    Comment


    • #3
      The real code has been simplified but maybe not enough...
      All environment variable are set at the system level so the issue is not comming from this point.

      It is the same as
      mirthconnect-3.0.3.7171.b1190-windows-x64.exe -q
      -Vsys.javaHome=%MY_JAVA_HOME%
      -Vsys.installationDir=d:\programs\MirthConnect
      -Vdir.appdata=d:\data\MirthConnect\appdata
      -Vdir.logs=d:\data\MirthConnect\logs
      -Vhttp.port=31486
      -Vhttps.port=31487
      -Vhttp.contextpath=/MirthConnect

      the topic is that dir.appdata (or dir.logs) contains relevant value at the end of the installation
      but I cannot use them as argument in the command line installation

      Is there any other idea?

      I'm probably confuse between install4j and mirth command line argument...

      Thank you for helping.

      Comment


      • #4
        A small precision...
        I have a fully working installation linked on postgresql database.
        The only trouble is this folder issue in automatic command line mode.

        Comment


        • #5
          Ah, I missed the details from the response file in your first post.

          Have you tried to specify an edited response file instead of the command line arguments? I believe it is "-varfile response.varfile". It's not as simple as the command line, but might work.

          Comment


          • #6
            The same behavior occured with the response file...

            So I create an issue for that MIRTH-3371

            Comment

            Working...
            X