No announcement yet.

Error Deploying Channels

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Deploying Channels


    I've one Channel in Routermode and two Destinations (hope, that this fact isn't the conflict?).

    Both Destination had a simple JS filter statment and as Destination an MySQL DB endpoint which is filled by a js statmenent (new JS Statement in the connection view Mirth 1.4).

    After I configured the channel this morning I can't deploy the channel anymore. In the event viewer I got following exception (snipped):

    org.mule.config.ConfigurationException: Failed to parse configuration resource "/usr/local/mirth-1.4.0/conf/mule-config.xml" (org.mule.config.ConfigurationException)
    at er.configure(
    at com.webreach.mirth.server.Mirth.startMule(Mirth.ja va:163)
    at com.webreach.mirth.server.Mirth.restartMule(Mirth. java:145)
    at )
    Caused by: org.mule.config.ConfigurationException: Failed to parse configuration resource "/usr/local/mirth-1.4.0/conf/mule-config.xml"
    at tion.process( 1)
    at er.configure(
    at er.configure(
    ... 3 more
    Caused by: org.mule.umo.lifecycle.InitialisationException: Initialisation Failure: missing ) after argument list (7411b688-501e-4709-9da1-32696035e6b7#9)
    at org.apache.commons.digester.Digester.createSAXExce ption(
    ... (some lines followed without any other excpetion only stacktrace, cutted for clearance)

    Has anybody an idea where the hell is my mistake? The channels runs very well with the old 'Call-Stored-Procedure-With-JS'-trick.

    I changed the mappings to transformer based mappings. So every HL7 parameter ist mapped to an var I put in the 'Connector Map' with transormation based on regexp and so on. Very nice ...

    Like to hear some hands on tipps

    Thanks in Advance for the great support I got in the past, hope that I could support others in the future.

    Hamm - Germany

    Addition 1:

    I ran from a shell and not in wrapped mode. When mirth tried to process a message this error occurs on the shell
    ERROR 2007-04-02 14:14:03,396 [317eac4b-d6b1-4455-bbe6-2838fae29f2c_source_connector._mllpEndpoint#-1992071333.receiver.2] com.webreach.mirth.server.mule.transformers.JavaSc riptTransformer: filter script could not be found in cache

    Can this two errors bind to each other?


  • #2
    Re: Error Deploying Channels

    This problem should be related with a JS syntax error. Try to check your JS steps, and your pre-proccesor steps.

    Using JS-MAP-STEP it's more difficult to find this problems (you can try to delete all, and add one by one)


    • #3
      Re: Error Deploying Channels

      Thanks a lot. I was beginning debbuging yesterday. I'll report the answer if I find one.

      Hamm - Germany


      • #4
        Re: Error Deploying Channels

        Is there any chance to map the hash object id to an real name which determines which JS script fails? Or is there a hint how to look into the derby db to select the object by its id?

        I know the hash and the line number but couldn't find the problem.

        I switched back to old plain js in one transformer as of time matters

        I'm looking forward for better debug outputs (script names?) in the mirth logs in future realeases. May I have to open a issue for it?



        • #5
          Re: Error Deploying Channels

          I suppose when you talk about the 'hash' you're refering to the JS or endpoint ID.

          You can find it in the conf/mule-config.xml file, which is generated after a deploy