Mirth Connect 4.1.0 Released!

Mirth Connect 4.1.0 is now available as an appliance update and on our GitHub page. Mirth Connect 4.1.0 includes new features such as new event log messages, additional fields to the Welcome to Mirth Connect screen, new information included in alerts as well as many smaller changes, updates, and improvements. This release also contains several improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Mirth with SQL Server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth with SQL Server

    Hello all!!!

    Someone is working with SQL Server for some time ?

    Can you help me about the configurations in the SQL Server ?

    I got some problems to see the events on the "Mirth Administrator".

    For example: Cause: java.sql.DataTruncation: Data truncation
    Caused by: java.sql.DataTruncation: Data truncation

    Do you know how to solve the problem ?

    Thanks all.

    Post edited by: Alexander, at: 10/30/2007 18:23

  • #2
    Re:Mirth with SQL Server

    Try increasing the column width in the table.

    For e.g, if the LastName column in the Patient table is varchar(15) and you send more than 15 character string data from Mirth, you could get data truncation error. In this case, you might want to increase the column width to, say, LastName varchar(30) and try.

    Hope it helps!


    • #3
      Re:Mirth with SQL Server

      Hi nshaik!

      Thanks for your help and sorry for my late reply!

      But the problem still happening!
      I just run the same script in two different servers.

      I'm just trying to do in the source a select and to retrieve the values to put in the destination using a insert statement getting the values from the source. But the problem still there.
      How could happen that problem if the tables are the same? Could be the SQL driver? Which driver should I use to access SQL Server?

      I got a new problem with date fields.
      Both servers are using the same format of date, but different languages. British and us_english.

      When I run the insert script in both servers, it works. But with Mirth is not working.

      I'm using the code below to try to help in the date problem.

      ************************************************** ***************
      var Ventrydate = "";

      if (msg['entrydate'].toString() != null) {
      Ventrydate = "'" + msg['entrydate'].toString() + "'";
      else {
      Ventrydate = "";
      channelMap.put('Pentrydate', Ventrydate);
      ************************************************** ***************

      I already tried a lots of ways. If you have got a solution comparing my case, please let me know.

      I'm getting lost with that problem.

      Thanks a lot mate. PHM___Sender.xml (55479 bytes)