Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Trouble with LLP Listener in Server Mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with LLP Listener in Server Mode

    First let me say what a great project. I am very impressed with the capabilities of MIRTH and am continually finding new uses for it at our center.

    I have setup some simple channels that forward ADT messages and one the creates Patient Labels and ships them to a printer. These are all working great.

    My current problem is that I am trying to define a channel that is uses an LLP Listener as its' source. I can get the channel to deploy and work correctly if it is listening to a port on the same host that is running MIRTH, but it won't connect if I set it up on a different host. For testing purposes I installed MIRTH on a second computer and was trying to use it as the listener, no joy. Is there something simple about setting up the network that I might be missing?

    Thanks in advance,

    Monty

  • #2
    Re:Trouble with LLP Listener in Server Mode

    Hi Monty.

    If I've understood you fine, you want Mirth listen LLP connection at other server than localhost. Unfortunatley This is a TCP/IP limitation: you only can listen to connection at your own host.

    Post edited by: albertosaez, at: 10/25/2007 13:44

    Comment


    • #3
      Re:Trouble with LLP Listener in Server Mode

      I had the same problem. When I changed the LLP listener to a client it worked fine.

      Comment


      • #4
        Re:Trouble with LLP Listener in Server Mode

        Ok, I get it. To be an LLP server I have to be "listening" on my own IP. I changed the IP to local host and the remote machine is now listening to the main machine. Thanks for pointing me in the correct direction.

        Monty

        Comment

        Working...
        X