No announcement yet.

Comma Delimited File

  • Filter
  • Time
  • Show
Clear All
new posts

  • Comma Delimited File

    Hi new to Mirth Trying something that I think should be simple.
    I am attempting to read a CSV file and write The single Numerical value from each record to a new file.

    The Test Channel below is testing writing to a File. My end goal is grabbing each value placing it in a variable and calling a web service with that variable

    Source : File Reader Reading in a file type
    - Process Batch Files Turned on
    - Record Delimiter Set to Comma
    I have attached Channel, screenshot, and test file
    All Help would be welcome...Please!!!
    Attached Files

  • #2
    The CDA file is one record not many.. I cant see any carriage returns?!


    • #3
      New to Mirth!
      trying to read a pipe delimited .txt file and write HL7 to a file.
      Do you have a sample file I can look at and, hopefully lear from?


      • #4
        Clarify Please

        glenn71 Not following. Do you mean that it is 1 Row with many columns instead of 1 column many rows?


        • #5
          The file is actually generated from a Web Service. I can Post the full results of that Webservice if that would be helpful...


          • #6
            Here is the full File. All I really want to do is take this result, then send each number to another "destination" or Channel that has another web service that process it with that number...I can't seem to get it to parse correctly..
            Attached Files


            • #7
              The problem is your delimited text data type properties are configured incorrectly.

              First, you have your record delimiter and your column delimiter set to exact same character. That's incorrect, as there would be no way to distinguish a new column from a new record.

              Second, you have Split Batch by Grouping Column enabled, but instead of a column name, you just have a comma in there. Even if you did have a name, you aren't specifying column names in the serialization settings so it wouldn't have worked anyway.

              You also have Split Batch by Delimiter enabled, even though as previously mentioned you have "by Grouping Column" enabled already. That doesn't make sense either. You can only split the batch one way (unless you're using JavaScript to do it), so you need to pick one. However here again, you've just placed a comma in there, which is the same as your column and record delimiters. So it's just going to ignore the delimiter because the record parsing will take precedence.

              The one thing you should have had enabled, Split Batch by Record, is disabled. If you want to indicate that the record delimiter is a comma, but you're disabling splitting the batch by record, then obviously the batch won't be split (or at least, not correctly).

              Go ahead and reset all your data type properties to the defaults. Then set your record delimiter to a comma, and set your column delimiter to something else (like a semicolon or something).
              Last edited by narupley; 03-14-2014, 02:41 PM.
              Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

              Nicholas Rupley
              Work: 949-237-6069
              Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.

              - How do I foo?
              - You just bar.


              • #8
                I had to many uncontrolled changes...
                Started over with clean slate applied changes that narupley suggested...Worked like a charm.

                Simplicity at its best....!!!!

                Thank You