Announcement

Collapse
No announcement yet.

Mirth FHIR Technology Preview 2 Released!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth FHIR Technology Preview 2 Released!

    We just released a new technology preview that will help you kick-start FHIR® support within Mirth Connect! This builds on our first technology preview with support for DSTU 2 and tons of new features!

    If you're familiar with the Fast Healthcare Interoperability Resources (FHIR) standards by HL7, you will probably have already realized that technically speaking, Mirth Connect has always been able to host and send to FHIR endpoints. The standards are based on RESTful HTTP, using either XML or JSON for the data format. Since we support all of those things, creating a FHIR-compliant channel has always been relatively easy.

    However, what this technology preview provides is an even easier way of doing this. The included FHIR Listener connector allows you to quickly host a FHIR server that auto-generates a conformance profile. In addition to that, built-in utility classes are included for handling FHIR responses. It can even auto-generate human-readable resource narratives and display them in a browser!

    Try it out, it's being released for free! All you need is Mirth Connect 3.3.0. Go here to download the preview: https://info.mirth.com/Fast-Healthca...rces-FHIR.html

    We also have a section of the public wiki dedicated to this, with a user guide and sample channel to get you started: http://www.mirthcorp.com/community/w...logy+Preview+2

    As always, please leave any feedback you might have!
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

  • #2
    Hi Nick

    I recently (last week) upgraded to Mirth Connect 3.3.0.7801 and downloaded the FHIR Technology Preview 2 extension. When I tried to install it using the Extensions menu (referencing the ZIP file) MC Administrator complained that 'Extension "fhir/source.xml" is not compatible with this version of Mirth Connect'.

    I'm running on an iMac under OSX 10.11.1

    Any suggestions?

    Regards
    john

    Comment


    • #3
      I am receiving this error as well.

      Mirth Connect 3.3.0.7801
      fhir-3.3.1.7856.b56.zip

      Comment


      • #4
        Hi all,

        same here in two different machines!.

        Ricard Bernat

        Comment


        • #5
          The latest FHIR technology preview is compatible with MC version 3.3.1. So you need to upgrade to 3.3.1 first, and then install the extension.
          Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

          Nicholas Rupley
          Work: 949-237-6069
          Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


          - How do I foo?
          - You just bar.

          Comment


          • #6
            Hi
            I'm interested in this new standard .
            I'm unable to download the Fhir listner, I fill the form (with iexplorer on windows) but I cannot download the zip.
            I get a timeout for the page after pressing the download button.
            Is there a place to download it elsewhere ?
            Thank you

            Paolo

            Comment


            • #7
              Hmm that's weird, I just tested and it seems to download fine for me. Maybe it's just intermittent network issues?

              If you can't get it to work, contact us directly and we can get the ZIP to you.
              Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

              Nicholas Rupley
              Work: 949-237-6069
              Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


              - How do I foo?
              - You just bar.

              Comment


              • #8
                Hi
                It worked after a lot of retries, with the latest version of windows internet explorer.
                It does not work under Firefox, where the form does not show.

                Thank you

                Paolo

                Comment


                • #9
                  FHIR Preview 2

                  I have Mirth 3.3.1.7856 using MS SQL as data base. I have installed FHIR extension. Stopped Mirth, deleted Java Cache, and restarted Mirth. When I go back in to Mirth extensions I see the FHIR extension listed. However w
                  hen I tried to create a FHIR listening channel there is not FHIR connector in the connector drop down box to select. Any ideas or help would be greatly appreciated. thank you

                  Comment


                  • #10
                    Originally posted by tldarr5371 View Post
                    I have Mirth 3.3.1.7856 using MS SQL as data base. I have installed FHIR extension. Stopped Mirth, deleted Java Cache, and restarted Mirth. When I go back in to Mirth extensions I see the FHIR extension listed. However w
                    hen I tried to create a FHIR listening channel there is not FHIR connector in the connector drop down box to select. Any ideas or help would be greatly appreciated. thank you
                    What is the exact filename of the extension ZIP you're trying to install?
                    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

                    Nicholas Rupley
                    Work: 949-237-6069
                    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


                    - How do I foo?
                    - You just bar.

                    Comment


                    • #11
                      Nick, I'm just wondering how the FHIR Listener will be tied to the SMART protocol with support of a bearer token?

                      Comment


                      • #12
                        Is there a version that works with the lastest version of Mirth?

                        Comment


                        • #13
                          Originally posted by rutledj View Post
                          Is there a version that works with the lastest version of Mirth?
                          Yeah, you should be able to go to the same site and download the latest version, compatible with 3.3.2.
                          Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

                          Nicholas Rupley
                          Work: 949-237-6069
                          Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


                          - How do I foo?
                          - You just bar.

                          Comment


                          • #14
                            Accept header

                            Hi, I was tested the extension and works great!!!

                            But we have a problem, extension doesn´t work with accept http header. FHIR can receive mime-type from _format query param or accept http header:

                            https://www.hl7.org/fhir/http.html#mime-type

                            With _format param works.

                            Regards

                            Comment


                            • #15
                              FHIR DSTU2 for 3.3.2?

                              The links to the FHIR DSTU2 Extension are currently targeting a version for 3.4. Is there a location where a version for the FHIR DSTU2 Extension for 3.3.2 can be found?

                              Thanks.
                              Brian Scheller
                              Mirth Fundamentals Certified 06/15
                              Mirth Advanced Certified 10/15

                              Comment

                              Working...
                              X