Announcement

Collapse
No announcement yet.

Building MIrth 2.0 in Eclipse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Building MIrth 2.0 in Eclipse

    Hi,
    I have been trying to build and deploy Mirth from Eclipse.
    I have executed all the steps necessary and that were mentioned @ http://www.mirthcorp.com/community/w...2.0+in+Eclipse

    I am successful with the build and when I am trying to run the configuration I get the following problem :

    java.lang.NoClassDefFoundError: com/mirth/connect/server/Mirth
    Caused by: java.lang.ClassNotFoundException: com.mirth.connect.server.Mirth
    at java.net.URLClassLoader$1.run(URLClassLoader.java: 202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:3 07)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 48)
    Exception in thread "main"

    I have the server directory in the class path.
    I dont understand why this is happening , can any one please help me with this.

    Thanks,
    Sathish

  • #2
    Eclipse comes with Ant 1.7.1 and you need to use version 1.8 or newer to build Mirth Connect. Install it separately, add it to your PATH, and run the build from the command line.

    http://ant.apache.org/
    Gerald Bortis | Chief Information Officer | Mirth Corporation

    Comment


    • #3
      run server error

      when ran the server after build. get the fellowing error:
      ////////////////////////////
      java.text.ParseException: Format.parseObject(String) failed
      at java.text.Format.parseObject(Unknown Source)
      at javax.swing.text.InternationalFormatter.stringToVa lue(Unknown Source)
      at javax.swing.text.InternationalFormatter.stringToVa lue(Unknown Source)
      at com.mirth.connect.plugins.messagepruner.MessagePru nerService.createTrigger(MessagePrunerService.java :98)
      at com.mirth.connect.plugins.messagepruner.MessagePru nerService.init(MessagePrunerService.java:80)
      at com.mirth.connect.server.controllers.DefaultExtens ionController.initPlugins(DefaultExtensionControll er.java:132)
      at com.mirth.connect.server.Mirth.startup(Mirth.java: 197)
      at com.mirth.connect.server.Mirth.run(Mirth.java:145)
      at com.mirth.connect.server.Mirth.main(Mirth.java:97)
      INFO 2011-03-23 11:23:25,312 [main] com.mirth.connect.server.Mirth: Mirth Connect

      Comment


      • #4
        I'm getting the same error. I installed MIRTH Connect, using Postgresql. I couldn't log in with admin, admin. I stopped MIRTH, then re-started. I get a prompt saying MIRTH server couldn't start. The MIRTH icon still goes to color from grey but I can't log in.

        Mirth Connect version 2.0.0.5127
        Java Version: 1.6.0_24

        RROR 2554-03-24 20:05:53,250 [Thread-1] com.mirth.connect.plugins.messagepruner.MessagePru nerService: error encountered in database pruner initialization
        java.text.ParseException: Format.parseObject(String) failed
        at java.text.Format.parseObject(Unknown Source)
        at javax.swing.text.InternationalFormatter.stringToVa lue(Unknown Source)
        at javax.swing.text.InternationalFormatter.stringToVa lue(Unknown Source)
        at com.mirth.connect.plugins.messagepruner.MessagePru nerService.createTrigger(MessagePrunerService.java :92)
        at com.mirth.connect.plugins.messagepruner.MessagePru nerService.init(MessagePrunerService.java:74)
        at com.mirth.connect.server.controllers.DefaultExtens ionController.initPlugins(DefaultExtensionControll er.java:116)
        at com.mirth.connect.server.Mirth.startup(Mirth.java: 163)
        at com.mirth.connect.server.Mirth.run(Mirth.java:126)

        Mirth server doesn't seem to be starting; can't log in.

        Comment


        • #5
          gisaac, it doesn't sound like you're building or running Mirth Connect from the source code in eclipse. If you're not, you might have better luck in the support forum.
          Jacob Brauer
          Director, Software Development
          NextGen Healthcare

          sigpic

          Comment


          • #6
            Concerning the error "error encountered in database pruner initialization": Can you check database in the table configuration whether there is a record:
            (Message Pruner; time; 12:00 AM).

            If NOT, add this record and restart mirth.



            Uploaded with ImageShack.us

            Comment

            Working...
            X