No announcement yet.

error occurred while creating a new channel

  • Filter
  • Time
  • Show
Clear All
new posts

  • error occurred while creating a new channel

    Hi All,
    I build and run the mirth from the source.after i run the application i am getting client UI successfully but while i tried to create a new channel it is telling that you must have atleast one source connector and one destination connector installed .

    if we click on channels in the left pane i am getting error like below.

    com.webreach.mirth.client.core.ClientException: method failed: HTTP/1.1 500 com.ibatis.common.jdbc.exception.NestedSQLExceptio n:
    --- The error occurred in postgres/postgres-channel.xml.
    --- The error occurred while applying a result map.
    --- Check the Channel.get-channel-result.
    --- Check the result mapping for the 'sourceConnector' property.
    --- Cause: com.thoughtworks.xstream.mapper.CannotResolveClass Exception: com.mirth.connect.model.Connector : com.mirth.connect.model.Connector
    Caused by: com.thoughtworks.xstream.mapper.CannotResolveClass Exception: com.mirth.connect.model.Connector : com.mirth.connect.model.Connector
    com.webreach.mirth.client.core.ServerConnection.ex ecutePostMethod(
    com.webreach.mirth.client.ui.Frame.retrieveChannel s(
    com.webreach.mirth.client.ui.Frame$16.doInBackgrou nd(
    com.webreach.mirth.client.ui.Frame$16.doInBackgrou nd(
    java.util.concurrent.FutureTask$Sync.innerRun(Unkn own Source) Source)
    java.util.concurrent.ThreadPoolExecutor$ Task(Unknown Source)
    java.util.concurrent.ThreadPoolExecutor$ (Unknown Source) Source)

    please suggest me the how to resolve this problem.can we modify mirth source to edit some source for production purpose.

  • #2
    Did you add the build directory to your classpath? I'm assuming you're trying to run it from your IDE?
    Jacob Brauer
    Director, Software Development
    NextGen Healthcare



    • #3
      Thank you for your reply ...
      Yes,I am running mirth 1.8.2 from eclipse IDE. i added mirth/server/conf,mirth/server/lib/,mirth/server/build to the classpath.but still i am getting same(above) problem.please suggest me if i miss something.
      Thanks in advance.