No announcement yet.

Code completion with loaded Java Libraries

  • Filter
  • Time
  • Show
Clear All
new posts

  • Code completion with loaded Java Libraries

    Is there anyway to have the code completion dialog show for custom java libraries? If not, does anyone have any suggestions on how make using java libraries easier? The only thing I could think of was to create code templates with the same signature as the java classes. I'd appreciate any advise

  • #2
    Technically yes, the Administrator client will search for any JARs on the classpath ending in "userutil-sources.jar", and automatically parse through the Java source files within to add them to the auto-completion dialog. Note that JARs on the client-side should be signed with a proper CA cert.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.

    - How do I foo?
    - You just bar.


    • #3
      I'm sorry, This might be a dumb question, But would that mean recompiling my jar files after specifying the classpath to be userutil-sources.jar? I've never dealt with Classpaths so my understanding is limited.


      • #4
        How to sign the jar?

        I tried to add my jar to the code completion but unfortunately it didnĀ“t work.
        I tried following steps:
        1. Compiled my jar file new
        2. Renamed it to "myJar_userutil-source.jar"
        3. Signed it with a self created certificate (Maybe this is the problem? )
        4. Copied the file to ...\Mirth Connect\client-lib
        5. Stopped and restarted Mirth Service and load the Administrator new from the Server Manager

        When the Administrator starts I get an error:
        JAR - Ressourcen in JNLP-File are not signed by same certificate

        Does this error occurs because of my self signed certificate?
        Or do I have another problem?