Announcement

Collapse
No announcement yet.

Struggling to build project in Eclipse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Struggling to build project in Eclipse

    I've followed the brief documentation on the mirth site to get the source code into Eclipse. Seems to be working well, but I've hit a bit of a wall now running the updated configs. When I try to re-build 'Server' I get a fail with the following general console error:

    Code:
    <terminated> Mirth Connect Server [java application] C:\Program Files\Java\jdk1.8.0_65\bin\javaw.exe
    
    Error: Could not find or load main class com.mirth.connect.server.Mirth
    I get more info from the descriptions:

    Code:
    Project 'Client' is missing required library: '/Server/setup/client-lib/userutil-sources.jar' 	Client	
    Project 'Server' is missing required source folder: 'build'	Server
    ~workspace/Server/setup/client-lib/userutil-sources.jar
    ~workspace/Server/build

    both exist. In the case of build it has three subfolders called

    client-lib;
    extensions;
    webapps.

    I'm thinking maybe something to do with Java paths? Here is an export of relevant vars:

    PATH=C:\ProgramData\Oracle\Java\javapath;C:\Window s\system32;C:\Windows;C:\Windo
    ws\System32\Wbem;C:\Windows\System32\WindowsPowerS hell\v1.0\;C:\Program Files\ap
    ache-ant-1.9.6\bin;C:\Program Files\Java\jdk1.8.0_65\bin
    Any ideas?

  • #2
    Hello amble,

    maybe it's too late, but i just saw your post now and i just finnish to config Mirth on inteliJ IDE following this tutorial.
    Is working with no errors, just follow the steps.
    Any problem contact me

    http://gurun.blogspot.pt/2013/03/mir...vironment.html

    Best Regards
    Best Regards,
    Alex Neiva

    Comment

    Working...
    X